Stencil-CLI 1.21.0 Release (Node 10 support)

by BigCommerce
Stencil CLI now supports environments using Node 10 To get this update, simply run npm install -g @bigcommerce/stencil-cli
Stencil
Enhancement
Announcement

Required stencil-cli version is now 1.20.2

by BigCommerce
As mentioned in a previous update, the required stencil-CLI version for local development is now 1.20.2. To update to the latest version of stencil-cli, simply run npm install -g @bigcommerce/stencil-cli. We recommend using the latest...
Announcement
Stencil
Warning

Storefront API now in Open Beta!

by BigCommerce
Our GraphQL Storefront API is now in Open Beta and available for use on any store using Stencil. The GraphQL Storefront API enables you to freely query storefront data on top of the BigCommerce Stencil theming framework. This means that...
Storefront API
Announcement

Stencil CLI minimum required version is changing on September 30th

by BigCommerce
On September 30th, 2019, the minimum required version of Stencil CLI will be raised to 1.20.2 from 1.8.0. After September 30th, you will not be able to run stencil start without being on at least the minimum supported version. This...
Announcement
Stencil
Warning

Stencil-CLI 1.20.0 Release

by BigCommerce
You can now specify your store URL, token, and port while running stencil init. Try it out! stencil init --url https://store.com --token myaccesstoken12345 To get this update, simply run npm install -g @bigcommerce/stencil-cli
Stencil
Enhancement
Announcement